Multiple FG32 devices behind router
| Support Home | Forums | Reply | Search |
Sedona Discussions Controls Discussion Forum / Sedona Discussions /

Multiple FG32 devices behind router

Author Arthur C...
Registered
#1 | Posted: 4 Oct 2017 22:36  
I have a site with 2 FG32 devices behind a cable modem/router. I can forward one of the device's Sox port and access it through the CPT tool, I can change the port forwarding to the other device's IP and it responds, but I can't get the both devices to respond. I've tried changing the Sox port of one device, I've tried several different forwarding strategies that should work, but I still have no luck.
Has anyone had success doing this?
Thank you!
Author Ian J...
Registered
#2 | Posted: 6 Oct 2017 13:46  
Hi Arthur,

I've got several sites which contain multiple fg's and 30P controllers all accessible with standard port forwarding rule setup - so yes this is possible and shouldn't present problems.

Are you specifying the port in CPT ( in the Port: box below the Host: ip address ) ?

You're not typing the ip AND port address into the HOST: box are you? - the only item in the HOST: box should be the ip address NOT the ip+port.
192.168.10.11 NOT 192.168.10.11:8080


If this doesn't sort it I can only say check your port forwarding rules in the router?

Let me know how you get on.

Cheers,
Ian.
Author Arthur C...
Registered
#3 | Posted: 7 Oct 2017 17:43  
Ian,
Thank you for the quick response! I do specify the port in the Port box. The router I'm working with has two types of ports to forward. Public (from outside the router) and Private (or internal after the router ) If I make the Public Port say "1888" and the Private Port "1876" and direct them to 10.0.10.65 I can access the first of the FG32s with no problem.
If I then make the other rule "1889" (public) and "1876" (the Sox Port of the FG32) private and direct that to 10.0.10.66 I get no response. Even if I change the Sox port to something other than 1876 in CPT (Service folder "Sox") I still get no response. How is your router forwarding set up to your multiple devices? Do you change the Sox port in the devices? Could the problem lie with the router?

Thanks,
Art
Author Ian J...
Registered
#4 | Posted: 10 Oct 2017 17:15  
Hi Arthur,

Hmmm.. very strange.

The only thing I can see is that you are only forwarding the 1876 sox port through the router - I've always forwarded the CPT tools through on port 1001 as well.


See below for the standard ports and network transport types:-


Protocol Port Type Remarks

Sedona (sox) 1876 UDP Sox connection

File Transfer Client (FTP) 21 TCP Graphics Deploy , File Transfer via FTP Client

Web Server 80 TCP Build In Web Server port

Tcom 5021 UDP Tcom Niagara Driver port

CPT Tools 1001 TCP&UDP CPT programming tools



Obviously you don't need the Tcom if you aren't connecting to Niagara.


I'd set up these rules ( obviously if you got a lot of FG controllers you will have to alter the port mapping to suit )

Let me know mate.

IJ.
Author Arthur C...
Registered
#5 | Posted: 3 Nov 2017 19:37  
Thanks, Ian,
I found the problem, operator error on my part. Gateway was off by one on the unreachable controller. Thanks for all of your help!

Best regards,
AC
Sedona Discussions Controls Discussion Forum / Sedona Discussions / Multiple FG32 devices behind router Top
Your Reply Click this icon to move up to the quoted message
 
 ?

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
  Controls Discussion Forum Powered by Bulletin Board Script miniBB ®